dimanche 11 avril 2010

libtool: link: cannot find the library `/usr/lib64/libGL.la

Suite à la mise à jour de ma Gentoo j'ai rencontré ce soucis de librairie.

libtool: link: cannot find the library `/usr/lib64/libGL.la' or
unhandled argument `/usr/lib64/libGL.la

Pour le corriger il suffit d'installer lafilefixer 

emerge lafilefixer

Puis de reconstruire l'index :

lafilefixer --justfixit

Partage

lundi 10 décembre 2007

Gentoo: Erreur de compilation de glibc-2.6.xx

Si vous rencontrez une erreure lors de la compilation de glibc en architecture amd64 et que ça vous affiche ce message d?erreur :

* ERROR: sys-libs/glibc-2.6.1 failed.
* Call stack:
* ebuild.sh, line 1701: Called dyn_compile
* ebuild.sh, line 1039: Called qa_call 'src_compile'
* ebuild.sh, line 44: Called src_compile
* glibc-2.6.1.ebuild, line 155: Called eblit-run 'src_compile'
* glibc-2.6.1.ebuild, line 150: Called eblit-glibc-src_compile
* src_compile.eblit, line 168: Called src_compile
* glibc-2.6.1.ebuild, line 155: Called eblit-run 'src_compile'
* glibc-2.6.1.ebuild, line 150: Called eblit-glibc-src_compile
* src_compile.eblit, line 179: Called toolchain-glibc_src_compile
* src_compile.eblit, line 122: Called die
* The specific snippet of code:
* make PARALLELMFLAGS="${MAKEOPTS}" || die "make for ${ABI} failed"
* The die message:
* make for amd64 failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.6.1/temp/build.lo

la solution est toute simple :

emerge -C sys-devel/gcc-config
emerge --resume -avDNu world

Et le tour est joué

Partage

dimanche 9 décembre 2007

Gentoo: !!! emake i18ndir failed

Voici la cht?yte erreur que j?ai eu lors d?un

emerge --update world

Donc la manipulaton à réalisé est de vérifié si toutes les dépendances sont valide avec :

revdep-rebuild

Et si ça vous mentionne :

command no found

et bien il faut compiler :

gentoolkit

et le tour est joué

Partage