Suite à la mise à jour de ma Gentoo j'ai rencontré ce soucis de librairie.

libtool: link: cannot find the library `/usr/lib64/libGL.la' or
unhandled argument `/usr/lib64/libGL.la

Pour le corriger il suffit d'installer lafilefixer 

emerge lafilefixer

Puis de reconstruire l'index :

lafilefixer --justfixit